Completely impossible to escape 3 bowmen on horse at start


#1

There is something seriously wrong with the scripting in the scene in the beginning where you have to escape on horse while bleeding with 3 soldiers chasing you and never leaves more than 2m away from you just firing arrows in to you all the way. after retrying this scene now 10 times in a row and being shot to death all 10 times within 30 seconds in this scene i have now tried everything and concluded it is not possible to advance through that challenge. I have dismounted the horse, i have tried to fight them with my sword, i have gallopped to the left into the forest and to the right on the field. I have gallopped on the road following the marker, i have slow-paced along the road. it does not fking matter, im dead in 30 seconds with 8 arrows in my chest. and every single time i have to start over from fleeing this 1 guy at the castle because its NOT POSSIBLE to save while in combat! Frustrating as hell and completely destroying my game experience. This 11th time I was on horse and tried to use a potion to cure light wounds i took from my house. BOOM! Game crashed, “stopped responding” and back to Windows. Thanks alot, I’m done, not playing this crap anymore until this gets fixed. Sorry for the harshness, just completely FRUSTRATED with this game already after 1 hour playing. ARGHHHHHHHHHHHHHHHHHH


Pferd und Flucht im Tutorial
#2

Yeah, this part is not pleasant experience :smiley:
Although, I just played it and made it on first try.
Galloping isnt really enough - you have to sprint. Double tap LSHIFT with W to sprint - while sprinting cumans can´t shoot at you (usually).
Your horse will run out of stamina eventually, BUT when you do, release LSHIFT, press it one time - you will now gallop - use your mouse to look behind you and do zig zag if you see them draw a bow. After 3-5 sec you have enough stamina to start sprinting again! Two cycles and you are there.

OR - dont dismout - just draw your sword on horse and start slashing them :slight_smile: This is in fact very, very effective :smiley:


#3

I did it on the first try… did you run into the right direction? That’s not meant to sound rude or anything, but I’ve heared that several people apparently ran into the wrong direction in the first place… you need to turn to the left when you come out of the moat and keep running, otherwise more cumans will follow and attack you, making the whole thing a lot more difficult.


#4

Well, you just need to use your brain and ride in the right direction. :smiley:
Be sure to double-tap shift to ride faster.


#5

Did it on the first try, my brother needed “84783” tries (his counting … :wink: ).
Run, dont look back, ride and dont look back, watch your horse and you are good to go.


#6

But do not forget to save Theresa!


#7

How’d you manage that? …I left that wench to her fate.

Still feel bad about it :pensive:


#8

Just hit and run.


#9

The easiest way, just press x to whistle…
But after this mount and ride…!!!


#10

Lmao, 4 hours in and didn’t even knew that’s possible. Loving this game!


#11

I made it on first try as well :slight_smile:


#12

Needed about five tries to find out how to gallop properly :smiley:


#13

I used my favourite technique… smashing all the buttons on the controler and screaming at the screen :smiley:


#14

Tried 3 times. Only succesfully mounted the horse once. After i started riding , got to the cutscene , then the horse achers shot me during the cutscene. As soon as i regained control (loading after cutscene), i was bleeding and died within 3 seconds. I feel like i was being shot between the cutscene and loading. Almost like when you load into an online survival game in a dangerous place.

Anyway, the story and acting is second to none, but the clunky controls and this problem are affecting my desire to continue playing this game. The other two tries i had trouble mounting the horse before the dozen armored guys caught up and killed me.

I should say im playing on xbox.


#15

ps4, first time I died pretty quick, then realized i needed to double tap to ride faster. easy once you figure it out ride in the right direction. good luck


#16

Got slaughtered my first two times… then I got creative. Go off path, jump over things, open up distance. Leap over streams. By the time I got to the checkpoint, I couldn’t even see the horsemen behind me.


#17

If you ride fast enough can you avoid getting shot in the cutscene?


#18

no this shouldnt be possible


#19

I accomplished getting past the chase scene. During the cut scene i kept pushing forward on the controls and spamming gallop to get my horse riding as fast as possible, considering you start at a dead stop after the cutscene.

Then cut through grass etc as much as possible heading to the “left” toward the objective.

If you get hung up too long youre gonna die from the expert horse archers. (must be mongolians) . Also if you ride the horse too hard the green bar starts going down, and the horse starts bucking like its dying.


#20

It took me 4 tries before I was able to escape. The issues I had were controlling the horse. Often it’d go into a shallow ditch and I’d never be able to get it out. I was also unable to get ‘cruise control’ to work. It is possible, just take a break and try again.