No horses and horstrader in Merhojed


#1

After the Quest “the plague” There are no more horses in merhojed…know Somebody whether the appear later again?


Plötze nicht mehr vorhanden
#2

After Neuhof was raided it took ±one in-game week for horses to return, it may be similar for Merhojed, though in Merhojed all horses died, in Neuhof there were still a few left.
Obviously if you didn’t cure the people they’ll have died and there’s nobody to buy the horses from.
I don’t go to Merhojed often, but I’d say check back after one in-game week.


#3

May have to wait a bit, i am on ny second run through with Henry 2.0 and i saved up and bought Jenda before the plague of merhojed.


#4

Thanks for the answer…i cured the people…i will wait a Week and look again


#5

I cured everyone and there are some horses there now that you could otherwise buy, but there is no horse trader to buy from even though a couple of weeks have passed in-game.


#6

I have the same problem but I havent even had the quest the plague
I have to steal horses for miller woyzeck
it seems raided and there are 2 piles of burning dead horses


#7

Futhermore, the best horse of the game (i think) is in stable of Merhojed.
And its impossible to see some new horses.


#8

Yes, Jenda in Merhojed is the most balanced and expensive horse in the game. But After the plague all horses in merhojed are away


#9

Or Dead for the rest of the game


#10

I just got to Merhojed after the Nest of Vipers quest was just informed about the plaque and there are no horses at all.I at least have the warhorse Jenda and every time I get on her the game says bring it to Woyzeck.So do I have to reload or will the horse come back later as mentioned about don’t care if I can’t buy them just need to steal one?


#11

I have a similar problem. I have completed “nest of vipers” but haven’t started the “Plague” mission .
Unfortunately when I get to Merhojed there are no horses at the trader to steal for Woyzeck. There’s a big white cross on one of the doors and a fire at the edge of the village (which I’m guessing are the expired equines).

Is this quest path now broken?


#12

Sent a ticket to support. Will post any news.


#13

What’s wrong with this? A plague erupted and killed all animals.

The miller will have to forget about his horse.


#14

This breaks the quest line progression.


#15

How long time is needed to wait until is clear up, if cure would work or not, im waiting for long, long time and still not quest update… Or its trigged by some main quest progress?


#16

It’s clearly (another) broken thing in this broken game…
I cured the people, imprisoned the bandit in Rattay, waited for at least 10 days, received rep boost with villagers for curing them but all of them are now just standing around village or near their “sick beds” complaining about that bandit. Looks like some script hung up.
1.4 or 1.4.1 didn’t fix this. This game is a scam.


#17

Complete the main quest “All that Glisters”. Horses should come back .


#18

I’ve done that long time ago.
No horses in Merhojed still. Mathias still laying in stable. Cured people still standing on their spots/beds and shouting at Melichar for hiding the bandit. Guards are patrolling the streets like nothing happened and Melichar is walking around the village. The horse trader is missing.
I’ve completed this quest fully before the 1.4. atrocity and cured all the people with correct medicine.
It’s still bugged (1.4.2).


#19

Hmm. I’m not sure then. For me the town went back to normal as soon as I completed “All that Glisters.”


#20

I have the same problem with not being able to buy warhorse Jenda in Merhojed. I came to stables there before the Pestilence quest and Yohann the trader wasn’t selling any horses at all, I tried many times to come back and nothing. Jenda is my favorite horse and I am mad that I can’t buy it. Then I waited to see what happens after Pestilence quest and now there are no horses at all and Yohann isn’t selling any. This is my 3rd playthrough and I had no issues with buying Jenda before, this time it’s all messed up. By the way I cured all the villagers, did everything I could, obviously many animals died but it was the same before in my previous playthrough. I am playing after patch 1.6.2 and this patch introduced tons of new bugs, including people missing torsos - they are hollow under clothes, I would say 30 percent of NPCs are affected by it - they are hollow on the inside and you can see it because parts of their dresses or jackets are missing too. Crazy.