No random encounters


#84

I had no Problem with the horserace, but always saved the game to make sure Encounters still occur. After Timmy they were gone. When I reloaded and played the quest again differently i still had Encounters.
This was before the patch. Now I also have the Impression that random Encounters don´t happen as often as before the patch.


#85

Did latest Patch or Patch coming out going to fix No Random Encounters on Console?


#86

I had one random encounter saying she was an infamous musician and she wanted to perform for Henry, She played the skin flute… Really funny quest


#87

Well, at least I know that I’m not alone with this problem… not having random encounters really sucks, it takes away the little goosebumps that you get while traveling :frowning:


#88

no it didnt. Devs have not said a word either.


#89

I’m having the same problem. I did install the mod mentioned, but i wasn’t having encounters anyway. In any case, i’ve uninstalled the mod, but the problem persists.

It’s really a shame, i liked most of the random encounters :frowning:


#90

Hello Henrys

Just for some people that don’t get random events anymore I thought this might be helpful.
I was searching how to get my random events back and found this.

You can debug random events and increase their appearance.
All you need is restricted console variables unlocker mod ( nexus mods )
Replace whgame.dll in your data folder and type in console or create user.cfg

wh_pl_randomeventsdebug ( 0 default / 1 debug )
wh_pl_randomeventscooldownsenabled ( 1 default (my setting)
wh_pl_randomeventbasechancerunoffset ( 0 default / 1 chance increase ) (a lot)

I dont have it confirmed but it works for me and ofc at your own risk. thx


#91

The latest patch seemed to fix my random encounters, now I get a few each quick travel. Thanks WH!


#92

I started a new game after the patch, and after 30 hours I haven’t had one random encounter! I had the dangerous roads mod on, not sure if that’s why. This is killing me!


#93

Roads are dangerous mod is not updated. Uninstall that


#94

I’ve played about 5 hours (real time) with the new mod and had zero random encounters of any kind :frowning: Will try Hornet’s fix tomorrow :slight_smile:


#95

First thing I did was remove the mod but still nothing after several hours. Tried fast traveling from one side of the map to the other dozen times, but still nothing. Im going to start a new game again with no mod to see if that fixes it. Sucks because this is one of my favorite features on the game.


#96

Yeah mine too. Try what I wrote below. Now I have so many events I dont know what to do first haha

You can debug random events and increase their appearance.
All you need is restricted console variables unlocker mod ( nexus mods )
Replace whgame.dll in your data folder and type in console or create user.cfg

wh_pl_randomeventsdebug ( 0 default / 1 debug ) I set to 0 right after that
wh_pl_randomeventscooldownsenabled ( 1 default (my setting) / 0 didnt have encounters )
wh_pl_randomeventbasechancerunoffset ( 0 default / 1 chance increase ) (a lot)


#97

Sweet! I’ll try that. Better to many than non level at all. Of all else fails I’ll give this a shot. Thanks for the info, I appreciate it!


#98

Yay! I hope this patch does the same for the PS4 version!!


#99

Hi, I also tried to delete all saves, reinstall the game but it dooesn´t help me. Did you try the solution adviced by Hornet? I tried to download the newe whgame.dll from nexus mod and then do a change in the console, but it seems it doesn´t help me. Maybe I´m doing something bad.


#100

Awesome! I hex edited the dll myself and changed those to:

wh_pl_randomeventsdebug 1
wh_pl_randomeventscooldownsenabled 0
wh_pl_randomeventbasechancerunoffset 1

And random encounters are back again!


#101

Can i type the code in the user.cfg i already have, or do i need to make a new one?


#102

Yes I added it to the bottom of mine, my whole user.cfg is:

sys_job_system_max_worker = 8 – Sets the number of threads to use for the job system
sys_main_CPU = 1 – Specifies the physical CPU index main will run on
sys_physics_CPU = 2 – Specifies the physical CPU index physics will run on
sys_streaming_CPU = 3 – Specifies the physical CPU file IO thread run on
e_ParticlesThread = 4 – Enable particle threading
ca_thread0Affinity = 5 – Affinity of first Animation Thread.
ca_thread1Affinity = 6 – Affinity of first Animation Thread.
r_WaterUpdateThread = 7 – Enables water updating on separate thread (when MT supported).
e_StatObjMergeUseThread = 8 – Use a thread to perform sub-objects meshes merging
r_TexturesStreamingMaxRequestedMB = 4000 – Disk Read Speed
sys_budget_sysmem = 16384 – 16 GB Ram
sys_budget_videomem = 8192
r_TexturesStreamPoolSize = 4096
r_TexturesStreamingResidencyTime = 120
r_texturesstreamingDeferred = 1
r_TexturesStreamingResidencyEnabled = 1
r_TexturesStreamingMipBias = -1
r_TexturesStreamingResidencyThrottle = 0.8
e_PreloadMaterials = 1
sys_PakStreamCache = 1
sys_preload = 1
r_Sharpening = 0
r_vsync 1
sys_spec_twtoggle 2
r_ssdo=1
r_ssdoAmountAmbient=1.42
r_ssdoAmountDirect=2
r_ssdoAmountReflection=2
r_ssdoHalfRes=2
r_ssdoRadius=0.3
r_ssdoRadiusMin=2
r_ssdoRadiusMax=0.1
e_svoTI_SSAOAmount=1.4
wh_cs_playermaxopponentdistancetolock = 8
wh_cs_playermaxopponentdistancetounlock = 8
wh_cs_playerunlocktimeout = 0
wh_cs_playerverticalunlockdelay = 0
wh_cs_playerhorizontalunlockdelay = 0
wh_cs_playerlockopponentanglebias = 2
wh_cs_playermaxopponentangletolock = 0.8
wh_cs_playermaxopponentangletounlock = 0.8
wh_cs_playerinputcombatunlockdelay = 0
wh_cs_playerinputcursorunlockdistance = 0.05
wh_cs_playerinputlockingtolerance = 20
wh_cs_playerinputlockareawidth = 0.6
wh_cs_playerinputmouseunlockxthreshold = 60
wh_cs_playerinputmouseunlockmintime = 0
wh_cs_playerinputmouseunlockreturntime = 1.5
wh_cs_playerinputmouseunlockminoppangle = 20
wh_pl_randomeventsdebug 1
wh_pl_randomeventscooldownsenabled 0
wh_pl_randomeventbasechancerunoffset 1


#103

Ok thanks! Sadly. It doesn’t seam to work for me :frowning: