R2 ps4 not working

Feb 14 1020am: Control’s still don’t work. Wtf is this shit? Way to deliver, how much of that crowd funded cash was actually spent on developing this game?

And whoever mapped the controller needs to go back on their autism medicine.


@ExileActual u can fix this glitch your self as the next patch will be in 2 weeks u can switch the switch L2 an R2 in the button assignment section of your ps4 to fix this glitch till a official patch is released. give the game a chance ive played it for 25h now this is the one and only glitch ive encountered and so far i give the game an easy 9,5

@Zero_0200 thanks, I’ll give it a try. On the other hand we shouldn’t hafta do this and the controlls should be intuitive with “usual” controller lay out. Circle to run and square to jump?

Thanks again for the tip— I’ll try it.

I have switch the R2 to the L2 and now if i AM on a Fiat figth and press R2 the game ler me Kick but if it is sword figth dont let me Kick

Not enough of us have the bug for it to be a huge priority. That’s the sad fact, but they are aware of it. There is a patch coming in two weeks and I’m assuming the problem will be fixed within that patch. I would be very surprised if they did anything else before then. But yeah we don’t matter enough in numbers to warrant any acknowledgment and that’s what we are …numbers … feels so good to be just a number under the almighty dollar :dollar:

guys read here

We really believe this is the issue.
So if anyone else can confirm that switching to different controller or adjusting the analog button works.
We can then discuss what to do next eg. lowering the trigger value for attacks.

Attacks need 90% of trigger value pressed. but in menu any trigger value is enough.
Simply put your R2 button is slightly worn out

daniel vavra on twitter

my R2 was not working 70% of the time i switched it to L2 now and both now work just fine. so i can conform to you that if you change R2 to anyother buttom it works lets say u switch it to circle, circle will be attack and r2 will be sprint the problem is just with R2 using it for slashing if you use it for anything else it works am 100% sure as i tired it.

Lol. My R2 On my new controller doesn’t work either. Unless I press super hard. So thats all BS. Thanks warhorse, try again

1 Like

I got a new controller and the R2 only works if I press super hard. So it’s a new controller with the same issue. I guess we keep trouble shooting eh?

1 Like

I’ve got a new controller (recently upgraded to a PS4 Pro) and haven’t experienced the R2 issue at all!

PS4 users are not the only ones with this issue, combat is hindered and delayed as well on xbox one. Warhorse needs to hear the consumers and issue a patch that fixes the combat across all platforms.

1 Like

I’m also having the same issue with the Xbox one. In combat I’m unable to slash my sword with RT.
I can only stab by pressing RB.

I’m playing on a ps4 and the 1.03patch did not fix the r2 problem.

I’m very disappointed with myself for dropping almost 60$ on this game. I think it’s crap, the story line seems solid and I want to get into it but but the combat and even just strolling around town trying to pick objects up is extremely clunky. It has the feel of a ten year old game. Did I mention all the bugs? It doesn’t really matter, I’m done with turf and you lost a customer.

So this problem hasn’t been fixed yet?

This is propablly cause by your controller. Anyway we´ve done some tweaking how far you need to press the trigger to attack, so from version 1.2.5 (patch v1.04) you should be able to attack even on controllers that are little faulty. This problem can be fixed with remaping R2 to any other button in the settings of your PS4.

Have a good day.
email: jan.rucker@warhorsestudios.cz

Still not working, btw. Ps4, 1.2.5

1 Like

Still not working for me post patch either.

1 Like

R2 button still not working. Isn’t this easy to test before patches go through? lol